This project is read-only.

Setting https for the login page

Jan 19, 2015 at 9:48 PM
I need to set up my website so the login page is secure and using https. is there an easy way to set https in sageframe?
Jan 20, 2015 at 10:28 AM
Dear Sir;

To manage SSL You need to go in dashbaord(C-Panel) and click on portal setting and on Superuser setting tab ,click on SMTP Server Setting and
check on SMTP Enable SSL.

Then go to Default.aspx.cs file and uncomment the ManageSSLConnection (); line of SageInitPart();
like on this line
   SageInitPart();
        // ManageSSLConnection();Uncomments this line.
After this you need to go to server setting and enable SSL .

Thank you

Regards:
Support Team
Jan 23, 2015 at 3:55 PM
Hi,
How can I enforce https:// of the page. We don’t want the user to have the ability to change it to http
Thanks
Feb 3, 2015 at 4:15 PM
Can anyone follow up with me on this issue?
Feb 4, 2015 at 5:27 AM
Dear Sir;

How are you. Here is some code for you where you can set up the rule in web Server or you can asks your Service Provider.

Here is a code for you to setup the rules:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
    <rewrite>
        <rules>
            <clear />
            <rule name="Redirect to https" stopProcessing="true">
                <match url="(.*)" />
                <conditions>
                    <add input="{HTTPS}" pattern="off" ignoreCase="true" />
                </conditions>
                <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Permanent" appendQueryString="false" />
            </rule>
        </rules>
    </rewrite>
</system.webServer>
</configuration>

Thank you.

Regards:
Support Team.
Feb 4, 2015 at 6:01 PM
When I added this code to the web.config I got a Server Error 500. What else can I do?
Feb 5, 2015 at 6:55 AM
Dear Sir;
How are you. Sir I would like to asks weather you have SSL License or you may asks to your service provider about the license.

Thank you.

Regards:
Support Team
Feb 5, 2015 at 3:11 PM
Yes we have an SSL license
Feb 10, 2015 at 5:00 PM
Can someone please follow up with this we do have the SSL license.
Thanks.
Feb 12, 2015 at 11:42 PM
Is there a way I can get an error log of what is happening with the 500 error?
Feb 13, 2015 at 2:56 AM
as soon as I add the code
<rewrite>
    <rules>
        <clear />
        <rule name="Redirect to https" stopProcessing="true">
            <match url="(.*)" />
            <conditions>
                <add input="{HTTPS}" pattern="off" ignoreCase="true" />
            </conditions>
            <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Permanent" appendQueryString="false" />
        </rule>
    </rules>
</rewrite>
I get error 500 anyone can help