This project is read-only.

IIS Error

May 22, 2012 at 3:56 AM


i installed IIS 7.5 in my system and tried to install sageframe again but it displays some App Pool IIS error. Before i was using IIS 7. I was able to install sageframe successfully. Isnt sageframe compatible in IIS 7.5?

May 22, 2012 at 5:39 AM

Hi spunkgeek,

Yes SageFrame is compatible in IIS 7.5 also, you can use it.

As for the App Pool IIS error,

All you need to do is to change that setting on your machine.

Use IIS Admin – Application Pools.
1- Right mouse click on DefaultAppPool row,
2- Select Advanced Settings,
3- A first setting under Process Model group is Identity,
4- Select it and using a drop down list change Built-in account from ApplicationPoolIdentity to NetworkService.

Now check your application log in, it will work


For more detail you can check


Hope this will work for you.




May 22, 2012 at 8:32 AM

Hello alokkumarpandey,

thanks but it is still showing the problem. Is there any other way ?

May 22, 2012 at 11:01 AM

Would you please mention which version of you are using? If you are using 4.0 application pool, try switching to the pool with 3.5. But I m not sure.

Please post a screenshot of the error if possible.


May 22, 2012 at 2:25 PM

Hi spunkgeek,,

i think there is problem with the permissions. I has once faced it for the first time when i tried to install sageframe 1.1. By default, users are not granted permission to access the database for your local MSSQL for example: sa. Try granting permission for our user as db_datareader, db_datawriter and db_owner. Please refer the link for adjusting the settings.

Hope it will help you !



Manika Limbu

May 25, 2012 at 8:18 PM

Hi codesack,

i have been using 3.5 itself.

Hi manikalimbu,

you were right. thanks it was the problem due to permission. my sageframe is working good now. thanks guys.